ئاندرويد 9 نەشىرىدە كونا ئەپلەر ئىشلىمەيدۇ
     ئونۋېرسال   جەمى 0 باھا

ئاندرويد 9 نەشىرىدە كونا ئەپلەر ئىشلىمەيدۇ

     ئونۋېرسال     جەمى 0 باھا

رەسىم چۈشەندۈرۈلىشى

iOS 10 دىن باشلاپ ئالما 32 بىتلىق ئەپلەردىن ۋاز كەچكەن. بۇنىڭ بىلەن سىستېمىنىڭ راۋانلىقى، ئۈنۈمى تېخىمۇ يۇقىرى كۆتۈرۈلگەن. ئەمدى ئاندرويد 9 مۇ مۇشۇ تەدبىرنى قوللانماقچى. ئەپ ئاچقۇچىلار گوگۇلنىڭ ئاندرويد 9 قاچ چىقارغان بىر تۈرلۈك يېڭى قائىدىسنى بايقىغان. يەنى Android 4.1 ياكى ئۇنىڭدىن بۇرۇنقى نەشىردىكى ئەپلەر يېڭى سىستېمىدا ئىجرا بولمايدۇ.

ئاددىيلاشتۇرۇپ ئېيتقاندا گوگۇل ئاندرويد 9 تىكى SDK غا يېڭى بىر تۈر MIN_SUPPORTED_TARGET_SDK_INT نى قوشتى. ئەگەر ئەپ بۇ يېڭى ئۆلچەمنى قوللىمىسا ئۇنداقتا ئۇ ئەپنى قاچىلىغىلى، ئىشلەتكىلى بولمايدۇ. (SDK نەشىرى v17 ، ئاندرويد نەشىرى 4.2 دىن يۇقىرى بولسا بۇ ئۆلچەمگە چۈشىدۇ) ئەپ ئاچقۇچىلار مەۋھۇم تەقلىدلىگۈچ مۇھىتىدىكى Android P دا Android 4.1 تىن بۇرۇنقى ئەپلەرنى قاچىلغاندا قاچىلىنىپ، ئىجرا بولىدىغاندا «ئىشلەتكىلى بولمايدۇ» دەپ خاتالىق ئۇچۇرى چىقىپ، ئىجرا بولمىغان.

Android ئۇچۇق كودلۇق سىستېما، ئەمما گوگۇل ئاندرويدنىڭ ئەركىنلىك دەرىجىسىنى تەدرىجىي تارايتماقتا. ئەپلەرنىڭ يۇشۇرۇن API زىيارەت قىلىش ھوقۇقىنى قۇلۇپلاپ قويدى. بۇنىڭ بىلەن ئۈسكۈندىكى كامېرا دېگەندەكلەرنى ئىشلەتكۈچىنىڭ رۇخسىتىسىز ئىشلىتەلمەيدىغان بولدى. شۇنىڭغا ئوخشاش ئاندرويد ھەر قېتىم چوڭ يېڭىلانغاندا بىر قىسىم چەكلىمىلەر قوشۇلۇپ، بارغانسىرى «يېپىقلىشىپ» iOS سىستېمىسىغا ئوخشاپ قېلىۋات

كۆرسەتمە